


Exhibio™ Enterprise Server Administrator’s Guide: Version 1.1	

Dear Exhibio Digital Signage Customer,

Congratulations on the purchase of your new Exhibio Enterprise Server! We appreciate 
your business. For the best use and operation of the Exhibio Digital Signage Solution, please 
read through this Administrator’s Guide and the Software User Manual before making any 
adjustments, and retain this document for future reference. We hope that you will enjoy working 
with your Exhibio Digital Signage Solution.

For assistance, please contact Exhibio at the following:

Phone:	 Within the USA:	 877.EXHIBIO (394.4246)		
	 	 International: 	 1.716.799.0410
		  Please listen to the prompts for Exhibio Support.
Web:		  http://www.exhibio.com/support

To purchase or inquire about accessories or other Exhibio products, please visit our website at 
http://www.exhibio.com or call the toll-free number above.

We highly recommend you register your system, either through the Enterprise Manager, via the 
web at http://www.exhibio.com/registration or by mailing in your registration card so that you 
may receive important information updates.
For peace of mind, and to protect your investment beyond the standard warranty, contact 
Exhibio for extended warranty contracts.

Write down your serial number located on the side of the system, or place the sticker from the 
shipping box here:

Serial Number 							     

Purchase Date 			 
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SYSTEM OVERVIEW

SYSTEM OVERVIEW

Exhibio™ Enterprise Digital Signage System
The Exhibio™ Enterprise Digital Signage System is a collection of devices and services designed for 
the purpose of easily and efficiently creating and displaying digital signage content in a number of 
geographically dispersed locations.
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System Dependencies
The Exhibio™ Enterprise Digital Signage System employs several interdependent services outlined in the 
diagram below.

 

Definitions

Enterprise Manager - A web-based user interface for managing content and playback of data on multiple 
Exhibio™ Enterprise Smart Terminals. It runs on the Microsoft IIS7 web server.

Database Server - Stores all the non-binary data for the Enterprise Manager. The Enterprise Manager uses 
Postgresql 8.4.

Subversion Server - A Subversion (svn) server that holds data that is synchronized between the Enterprise 
Manager database and its associated Smart Terminals. It also holds all of the Enterprise system’s binary 
media file data.
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Server Sync Service - A Windows service that periodically synchronizes all of the data from the Database 
Server to the Subversion Repository. 

Smart Terminal - Smart Terminals (STs) are remote devices deployed alongside displays in your Enterprise 
signage system.  STs play content that is created and scheduled in the Enterprise Manager.

ENTERPRISE SERVER SETUP

Initial Setup
Please follow these instructions when turning on your Exhibio Enterprise 
server for the first time:
1.	 Connect your server to a keyboard, mouse, and monitor.
2.	 Plug your server into a grounded outlet and press the power button.
3.	 After turning on your server, a Windows menu will appear on the 

monitor, asking you to confirm some basic information (country, time 
and currency, and keyboard layout). If you need to make changes, 
please do so.  Then click ‘Next’. 

4.	 Find your product key on the sticker affixed to your Enterprise server 
and type the key into the box. Then click ‘Next’.

5.	 Read over the Microsoft and Exhibio Software License Terms.  If you 
accept the terms, check the ‘I accept’ boxes and click ‘Next’.

6.	 Type in a name for the server.  This is how your server will be seen on 
your internal Windows network if used. 

7.	 Click ‘Start’.
8.	 When prompted, press your CTRL + ALT + DELETE keys.
9.	 Click the Administrator icon.
10.	 You will see a message saying that the user’s password must be 

changed.  Click ‘OK’.
11.	 Type in a new password to use for your server’s Administrator login.  

Confirm it by typing it again on the second line.  Please do not give out 
this password to anyone other than authorized systems personnel.  A 
different login is used when managing the content of your signs.  Click 
the arrow when done. 

12.	 A message will appear saying ‘Your password has been changed.’  Click 
‘OK’.

13.	 The Enterprise server’s desktop should now appear.
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CONFIGURING YOUR ENTERPRISE SERVER

Enterprise Server Desktop
The Enterprise desktop has icons that link to the Enterprise Configuration Utility, the Enterprise Manager, 
and the Enterprise Update Utility.  In addition, the Server Manager and other applications may be reached 
via the Start Menu.

Server Manager
When logged into your desktop, go to the Windows Start Menu and select Server Manager.  The Enterprise 
Server Manager will open, displaying information about your Exhibio system that may be of value to your 
system administrator.

When ‘Server Manager’ is selected in the left section of your window, you will see the Server Summary, 
Roles Summary, and Features Summary in the right window.  This is where you can set your server’s IP 
address and other important information related to your network.  

Adjusting Sync Frequency
Your Enterprise Server synchronizes changes from the Database Server to the Subversion Server at a 
configurable interval of time.  These changes include anything you may have added or updated in the 
Enterprise Manager that may affect what runs on a Smart Terminal, such as changes to scheduled scenes 
or emergency alerts.  By default, the synchronization interval is set to 30 seconds.  To change this number, 
execute the following procedure:

1.	 Log into the Enterprise Server’s desktop as a user with Administrator rights.
2.	 Double click the “Enterprise Configuration” icon on the desktop, or go to Start -> All Programs and run 

the “Enterprise Configuration” application.
3.	 Click on the “Server Sync Service” tab.
4.	 Adjust the number in the “Sync Frequency” box as desired.
5.	 Click the “Save” button.

You may wish to raise this number if you have a large number of Smart Terminals configured and find that 
your server is running slowly.   Raising this number will cause changes to the Smart Terminals to propagate 
less frequently.

Changing Subversion and Database Server Passwords
Your system has usernames and passwords configured by default for the Subversion and Database servers.  
There are two users for Postgresql and one for Subversion.  Postgresql has one Windows account that the 
service runs under and another synthetic account that is used as a login for the Web server application to 
interact with the Enterprise database.  The Subversion server has only one synthetic user account that is 
used by the Web server and Sync server as well as the Smart Terminals.  Changing either of the synthetic 
accounts will require changing login credentials in more than one location.

Postgresql Windows Account
To change the Postgresql Windows account, simply use the built-in Windows User Accounts control panel 
applet.  You will need to remember this information if you ever need to configure Postgresql backups or 
change the Postgresql database login account.

Postgresql Database Account
To change the Postgresql database login account, follow the steps below.
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1.	 Log into your Enterprise Server desktop as the “Administrator” user or another user in the 
“Administrators” Windows Group.

2.	 Go to Start->All Programs->Postgresql 8.4 and click on “pgAdmin III”.
3.	 Double click the “PostgreSQL 8.4 (localhost: 5432)” node under “Servers”.
4.	 Enter your Postgresql Windows account password.
5.	 Expand “Login Roles” in the tree-view.
6.	 Right click on the “exhibio” role and click on “Properties…”.
7.	 Enter your new password in the “Password” and “Password (again)” text boxes.
8.	 Click “OK”.
9.	 Double click the “Enterprise Configuration” icon on the desktop, or go to Start -> All Programs and run 

the “Enterprise Configuration” application.
10.	 In the “Connection String” text area under the “Database Server” tab, change the line that reads 

“Password=[old password],” replacing “[old password]” with your new one.
11.	 Click “Save”.

Subversion Account
To change the Subversion account password, follow the steps below:

1.	 Log into your Enterprise Server desktop as the “Administrator” user or another user in the 
“Administrators” Windows Group.

2.	 In Windows Explorer, click on Tools->Folder Options and select the “View” tab.
3.	 Under “Files and Folders->Hidden Files and Folders,” select “Show hidden files and folders”.
4.	 Click “OK”.
5.	 Navigate to “C:\ProgramData\SubversionRepositories\enterprise\conf”.
6.	 Open the “passwd” file in Notepad and change the line that reads “exhibio = [OLD PASSWORD],” 

replacing “[OLD PASSWORD]” with your new one.
7.	 Go to “File->Save” in the menu and close Notepad.
8.	 Double click the “Enterprise Configuration” icon on the desktop, or go to Start -> All Programs and run 

the “Enterprise Configuration” application.
9.	 Select the “Subversion Server” tab.
10.	 Under “Subversion Server Credentials,” enter your new password in the “Password:” and “Password 

(confirm):” text boxes.
11.	 Click “Test Connection” to ensure that the login information was entered correctly.
12.	 Click “Save”.

Once you have done this, you will need to log into each Smart Terminal that connects to your server and 
follow the steps below:

1.	 Connect to the Smart Terminal desktop locally using a keyboard and mouse, or remotely using VNC.
2.	 Hit <esc> to stop the sign.
3.	 Click on the “Setup” icon on the desktop.
4.	 Enter your Smart Terminal’s administrator password and click on the “Login” button.
5.	 Select the “Smart Terminal Registration” tab.
6.	 Under “Sync Service Credentials, enter your new password in the “Password” text box.
7.	 Click “OK”.
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UPDATING YOUR ENTERPRISE SERVER

Operating System Updates
Your Exhibio™ Enterprise Server runs on the Windows™ Web Server 2008 operating system.  Accordingly, 
you may use any of the tools provided by Microsoft for keeping the underlying operating system updated 
with the latest security updates.  Among these tools are Windows Update, and WSUS. You may choose the 
method for applying Windows Updates that is appropriate for your organization.

Exhibio™ Enterprise Software Updates
Exhibio™ may provide updates to the Enterprise Server software from time to time.  These updates are 
for the Exhibio™ Enterprise applications and services running on your server and are different than the 
Windows Updates described above.  The Enterprise Update application is provided to allow you to check 
for and apply Enterprise Software Updates.

Follow the steps below to use the Enterprise Update application.

1.	 Log into your Enterprise Server desktop as the “Administrator” user or another user in the 
“Administrators” Windows Group.

2.	 Either double-click the “Enterprise Update” icon on the desktop, or go to Start->All Programs and click 
on “Enterprise Update”.

3.	 Click the “Find Updates” button.
4.	 If no updates were found click “Finished”.  Otherwise, select any updates you wish to install and then 

press the “Install Selected” button.
5.	 Your updates will be downloaded and launched.  Follow any prompts in the installer.
6.	 Click the “Finished” button.

Once you update your Enterprise Server software, you may also need to update each of your Smart 
Terminals (via their desktops or a VNC connection) or they may not be able to get scheduled updates. 
Any Smart Terminals requiring software updates will be noted in the “Smart Terminals” section of the 
Enterprise Manager
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Considerations
Backing up your Enterprise Server is not a “one size fits all” task.  You’ll need to examine how data is 
stored in the Enterprise Server and assess how its backup strategy will fit into the backup strategy your 
organization already has.  Some questions you should ask yourself first, are “where do I want to store the 
data for my Enterprise Server backup,” “how often should I back up,” and “how much of my data should I 
back up at a time.”

The first thing you’ll need to know is where the data for your Enterprise Server is stored and whether or 
not it can be simply copied file by file over a period of time or requires an atomic “snapshot” of all the data 
at once.  Assuming that you can obtain a new fully-working installation of your server, all the data you need 
to bring a system back to its former state after a crash is stored in two locations, a Subversion repository, 
and a Postgresql database.  Backing up the Postgresql database will require special procedures beyond a 
simple file copy.  The Subversion repository, however, can simply be copied file by file.

A basic strategy that will work well and save space is to take a full backup of your system once and then 
copy over the Postresql and Subversion data regularly.  This way in the event of a catastrophic failure you 
can simply restore the original full backup and then restore the latest Postgresql/Subversion snapshot.  The 
only caveat is that the Postgresql backup must be taken prior to the Subversion Repository copy.

Alternatively, you may do a Postgresql backup and full system backup each time.  This will make the 
restoration process simpler, but it will also take up considerably more space on your backup media.

Backing up Postgresql
Detailed information on how to backup Postgresql can be found at the following URL: 
http://www.postgresql.org/docs/8.4/static/backup.html.  It is recommended that you read through that 
documentation first.  However, your backup could be as simple as setting up a scheduled task running as 
the postgresql user with the following command:

C:\Program Files (x86)\PostgreSQL\8.4\bin\pg_dumpall.exe > [PATH TO BACKUP FILE]

“[PATH TO BACKUP FILE]” is the location where you want your Postgresql backup to be saved.

Backing up Subversion
To back up your Subversion repository just copy over the following directory from your server.
C:\ProgramData\SubversionRepositories\enterprise

Note: This file copy must occur after you have backed up Postgresql.  Otherwise, your data may be out-of-
sync when you restore.



Exhibio® Dynamic Digital Signage
 

Copyright © 2011, Exhibio LLC.


